summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2022-02-10 04:35:21 +0100
committerGravatar Nikias Bassen2022-02-10 04:35:21 +0100
commit08aefcd597d26a5d99f64815a2b932c36f056164 (patch)
tree922d4fbc5d50b973fa08cc5ca5a99c148874b3b7 /Makefile.am
parente41dbc3ddbe30a414e73fa25d9c7c304ffe6989e (diff)
downloadlibimobiledevice-08aefcd597d26a5d99f64815a2b932c36f056164.tar.gz
libimobiledevice-08aefcd597d26a5d99f64815a2b932c36f056164.tar.bz2
autoconf: Automatically derive version number from latest git tag
with a fallback to get the version string from a .tarball-version file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4ef0813..b11de57 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,11 @@ SUBDIRS = 3rd_party common src include $(CYTHON_SUB) tools docs
EXTRA_DIST = \
docs \
- README.md
+ README.md \
+ git-version-gen
+
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version
docs/html: $(top_builddir)/doxygen.cfg $(top_srcdir)/src/*.c $(top_srcdir)/src/*.h $(top_srcdir)/include/libimobiledevice/*.h
rm -rf docs/html