summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2015-01-28 01:32:54 +0100
committerGravatar Martin Szulecki2015-01-28 01:32:54 +0100
commit64b1b1aa1eb53e47e3826f08f0cdc29d43a972b5 (patch)
tree79beea61702d5ee22ada725a7f76327dd19801cf /configure.ac
parentbf3223b972d60a82f394e8a2482f1b75c6caf0e4 (diff)
downloadlibimobiledevice-64b1b1aa1eb53e47e3826f08f0cdc29d43a972b5.tar.gz
libimobiledevice-64b1b1aa1eb53e47e3826f08f0cdc29d43a972b5.tar.bz2
Remove dev tools which are not installed and unmaintained anyways
Some might return as proper tools or be used as examples within the website documentation sooner or later.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 0 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 79e1590..c2678f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,26 +156,6 @@ else
AC_SUBST(ssl_requires)
fi
-AC_ARG_ENABLE([dev-tools],
- [AS_HELP_STRING([--enable-dev-tools],
- [build development helper tools (default is no)])],
- [build_dev_tools=true],
- [build_dev_tools=false])
-if test "$build_dev_tools" = true; then
- DEV_SUB=dev
- AC_CHECK_HEADERS([readline/readline.h],
- [],
- [AC_MSG_ERROR([Please install readline development headers])]
- )
- building_dev_tools=yes
-else
- DEV_SUB=
- building_dev_tools=no
-fi
-
-AM_CONDITIONAL([ENABLE_DEVTOOLS],[test "x$DEV_SUB" = "xdev"])
-AC_SUBST([DEV_SUB])
-
AC_ARG_ENABLE([debug-code],
[AS_HELP_STRING([--enable-debug-code],
[enable debug message reporting in library (default is no)])],
@@ -230,7 +210,6 @@ Makefile
common/Makefile
src/Makefile
include/Makefile
-dev/Makefile
tools/Makefile
cython/Makefile
docs/Makefile
@@ -244,7 +223,6 @@ Configuration for $PACKAGE $VERSION:
Install prefix: .........: $prefix
Debug code ..............: $building_debug_code
- Dev tools ...............: $building_dev_tools
Python bindings .........: $cython_python_bindings
SSL support backend .....: $ssl_provider