summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2024-06-16 15:53:29 +0200
committerGravatar Nikias Bassen2024-06-16 18:49:32 +0200
commit10cd5f7f0fe14fbf51f2142ea2df153da33d1a21 (patch)
tree2b445205092457cfecddd3e3a3396009d0f6c29a /configure.ac
parent4e95bd957981ba6bb1fc56d5f0f9781ed9fa8123 (diff)
downloadidevicerestore-10cd5f7f0fe14fbf51f2142ea2df153da33d1a21.tar.gz
idevicerestore-10cd5f7f0fe14fbf51f2142ea2df153da33d1a21.tar.bz2
Remove OpenSSL dependency in favor of libimobiledevice-glue's hash functions
This also removes the sha1/sha384 code from this repository since we are using the ones from libimobiledevice-glue now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 1 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index 25d1e95..d2c7f32 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,11 +19,10 @@ LIBIRECOVERY_VERSION=1.2.0
LIBIMOBILEDEVICE_VERSION=1.3.0
LIBUSBMUXD_VERSION=2.0.2
LIBPLIST_VERSION=2.6.0
-LIMD_GLUE_VERSION=1.2.0
+LIMD_GLUE_VERSION=1.3.0
LIBTATSU_VERSION=1.0.2
LIBZIP_VERSION=1.0
LIBCURL_VERSION=7.0
-OPENSSL_VERSION=0.9.8
AC_SUBST(LIBIRECOVERY_VERSION)
AC_SUBST(LIBIMOBILEDEVICE_VERSION)
@@ -33,7 +32,6 @@ AC_SUBST(LIMD_GLUE_VERSION)
AC_SUBST(LIBTATSU_VERSION)
AC_SUBST(LIBZIP_VERSION)
AC_SUBST(LIBCURL_VERSION)
-AC_SUBST(OPENSSL_VERSION)
# Checks for programs.
AC_PROG_CC
@@ -51,9 +49,6 @@ PKG_CHECK_MODULES(libzip, libzip >= $LIBZIP_VERSION)
PKG_CHECK_MODULES(libcurl, libcurl >= $LIBCURL_VERSION)
PKG_CHECK_MODULES(zlib, zlib)
-# optional
-PKG_CHECK_MODULES(openssl, openssl >= $OPENSSL_VERSION, have_openssl=yes, have_openssl=no)
-
AC_CHECK_FUNCS([strsep strcspn mkstemp realpath])
if test x$ac_cv_func_strsep != xyes; then
if test x$ac_cv_func_strcspn != xyes; then
@@ -156,32 +151,6 @@ fi
CFLAGS="$CACHED_CFLAGS"
-AC_ARG_WITH([openssl],
- [AS_HELP_STRING([--without-openssl],
- [Do not use OpenSSL])],
- [use_openssl=$withval],
- [use_openssl=$have_openssl])
-
-if test "x$use_openssl" == "xyes"; then
- if test "x$have_openssl" != "xyes"; then
- echo "*** NOTE: --with-openssl passed but OpenSSL is not available ***"
- use_openssl=no
- fi
-fi
-if test "x$use_openssl" != "xyes"; then
- echo "*** NOTE: Using internal SHA1 implementation ***"
- have_openssl=no
- openssl_CFLAGS=
- openssl_LIBS=
-fi
-if test "x$have_openssl" == "xyes"; then
- AC_DEFINE(HAVE_OPENSSL, [1], [Define if you have OpenSSL])
-fi
-AC_SUBST(openssl_CFLAGS)
-AC_SUBST(openssl_LIBS)
-
-AM_CONDITIONAL(USE_INTERNAL_SHA, test x$use_openssl != xyes)
-
AC_SUBST(GLOBAL_CFLAGS)
AC_SUBST(AC_LDFLAGS)
AC_SUBST(AC_LDADD)