summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2024-06-16 15:53:29 +0200
committerGravatar Nikias Bassen2024-06-16 18:49:32 +0200
commit10cd5f7f0fe14fbf51f2142ea2df153da33d1a21 (patch)
tree2b445205092457cfecddd3e3a3396009d0f6c29a /src/Makefile.am
parent4e95bd957981ba6bb1fc56d5f0f9781ed9fa8123 (diff)
downloadidevicerestore-10cd5f7f0fe14fbf51f2142ea2df153da33d1a21.tar.gz
idevicerestore-10cd5f7f0fe14fbf51f2142ea2df153da33d1a21.tar.bz2
Remove OpenSSL dependency in favor of libimobiledevice-glue's hash functions
This also removes the sha1/sha384 code from this repository since we are using the ones from libimobiledevice-glue now.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 0 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 88602e5..80f02f2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,7 +9,6 @@ AM_CFLAGS = \
$(libtatsu_CFLAGS) \
$(libzip_CFLAGS) \
$(zlib_CFLAGS) \
- $(openssl_CFLAGS) \
$(libcurl_CFLAGS)
AM_LDFLAGS = \
@@ -22,7 +21,6 @@ AM_LDFLAGS = \
$(libtatsu_LIBS) \
$(libzip_LIBS) \
$(zlib_LIBS) \
- $(openssl_LIBS) \
$(libcurl_LIBS)
AM_LDADD = $(AC_LDADD)
@@ -50,9 +48,6 @@ idevicerestore_SOURCES = \
limera1n.c limera1n.h \
download.c download.h \
locking.c locking.h
-if USE_INTERNAL_SHA
-idevicerestore_SOURCES += sha1.c sha1.h sha512.c sha512.h fixedint.h
-endif
idevicerestore_CFLAGS = $(AM_CFLAGS)
idevicerestore_LDFLAGS = $(AM_LDFLAGS)
idevicerestore_LDADD = $(AM_LDADD)