summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2022-12-10 02:22:12 +0100
committerGravatar Nikias Bassen2022-12-10 02:22:12 +0100
commita6775bc588db13838bebec42b139748d337e7189 (patch)
treed4e929e40bb8b2c812fcc38443033abf65bffdb6 /tools/Makefile.am
parentb314f04bd791b263cf43fadc6ac0756e67ab4ed0 (diff)
downloadlibimobiledevice-a6775bc588db13838bebec42b139748d337e7189.tar.gz
libimobiledevice-a6775bc588db13838bebec42b139748d337e7189.tar.bz2
tools: Add idevicedevmodectl tool
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index e8ef3ab..47e05b2 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -27,6 +27,7 @@ bin_PROGRAMS = \
idevicedebugserverproxy \
idevicediagnostics \
idevicedebug \
+ idevicedevmodectl \
idevicenotificationproxy \
idevicecrashreport \
idevicesetlocation
@@ -111,6 +112,11 @@ idevicedebug_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS)
idevicedebug_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS)
idevicedebug_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la
+idevicedevmodectl_SOURCES = idevicedevmodectl.c
+idevicedevmodectl_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS)
+idevicedevmodectl_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS)
+idevicedevmodectl_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la
+
idevicenotificationproxy_SOURCES = idevicenotificationproxy.c
idevicenotificationproxy_CFLAGS = $(AM_CFLAGS)
idevicenotificationproxy_LDFLAGS = $(AM_LDFLAGS)