summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7da967d..f44a6bc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,4 +25,7 @@ docs/html: $(top_builddir)/doxygen.cfg $(top_srcdir)/include/plist/*.h
rm -rf docs/html
doxygen doxygen.cfg
-docs: doxygen.cfg docs/html
+docs/README.doxygen.md: README.md
+ awk '/\#\# Table of Contents/{while(getline && $$0 != ""){}{print "[TOC]"}}1' README.md > $@
+
+docs: doxygen.cfg docs/README.doxygen.md docs/html