summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..837c1dd
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,25 @@
+AM_CFLAGS = $(GLOBAL_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/libcnary/include
+AM_LDFLAGS =
+
+noinst_PROGRAMS = plist_cmp plist_test
+
+plist_cmp_SOURCES = plist_cmp.c
+plist_cmp_LDADD = ../src/libplist.la
+
+plist_test_SOURCES = plist_test.c
+plist_test_LDADD = ../src/libplist.la
+
+TESTS = \
+ empty.test \
+ small.test \
+ medium.test \
+ large.test \
+ huge.test \
+ bigarray.test \
+ emptycmp.test \
+ smallcmp.test \
+ mediumcmp.test \
+ largecmp.test \
+ hugecmp.test \
+ bigarraycmp.test
+