summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorGravatar Chow Loong Jin2014-10-03 13:24:19 +0200
committerGravatar Nikias Bassen2014-10-03 13:24:19 +0200
commit305450ad5fc9d8027a35a67f3136d81e4ecf74e2 (patch)
tree8f159a64437e7bde96eceb00b7257f5c54948c3a /common/Makefile.am
parentcc4f7aa21edb54b6688aead32e8b8741247848c7 (diff)
downloadlibusbmuxd-305450ad5fc9d8027a35a67f3136d81e4ecf74e2.tar.gz
libusbmuxd-305450ad5fc9d8027a35a67f3136d81e4ecf74e2.tar.bz2
Move socket and collection functions to a convenience library
This avoids the iproxy tool from relying on undocumented library ABI.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
new file mode 100644
index 0000000..8acf04b
--- /dev/null
+++ b/common/Makefile.am
@@ -0,0 +1,14 @@
+AM_CFLAGS = $(GLOBAL_CFLAGS)
+
+noinst_LTLIBRARIES = libinternalcommon.la
+
+libinternalcommon_la_LIBADD =
+libinternalcommon_la_SOURCES = \
+ socket.c \
+ collection.c \
+ socket.h \
+ collection.h
+
+if WIN32
+libinternalcommon_la_LIBADD += -lws2_32
+endif