summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
new file mode 100644
index 0000000..8acf04b
--- /dev/null
+++ b/common/Makefile.am
@@ -0,0 +1,14 @@
+AM_CFLAGS = $(GLOBAL_CFLAGS)
+
+noinst_LTLIBRARIES = libinternalcommon.la
+
+libinternalcommon_la_LIBADD =
+libinternalcommon_la_SOURCES = \
+ socket.c \
+ collection.c \
+ socket.h \
+ collection.h
+
+if WIN32
+libinternalcommon_la_LIBADD += -lws2_32
+endif